Actualizar Ubuntu a la versión 11.04 desde la 10.10

De manera equivalente a la aquí reseñada:

Actualizar Ubuntu a la versión 10.10

procedí a actualizar Ubuntu a la versión 11.04 desde la 10.10. No obstante, debido a las novedades que se anuncian tendrá el Ubuntu 11.04 y que presagian que puede haber problemas, tal como se puede leer por allí en algunos feeds de noticias, tomo algunas precauciones para asegurar el éxito de la misma.

En primer lugar, para actualizar, en cónsola:

sudo su
[password de usuario]
gedit /etc/apt/sources.list

En este archivo, cambiar todo lo que dice maverick por natty, grabar y cerrar. En la misma cónsola:

apt-get update && apt-get dist-upgrade

A diferencia de la actualización que se encuentra en el link anterior, esta transcurrió con ruptura del sistema. De los más de 1000 paquetes que debían actualizarse y de los más de 200 paquetes nuevos que tenían que instalarse, algo más de 300 tenían conflictos de dependencia o tenían la imposibilidad de establecer archivos de configuración adecuados. No obstante, el sistema señalaba la “cura”. Hice nuevamente, pero por separado, un:

apt-get update

porque la actualización tenía como 3 días debido a la congestión de los servidores y un:

apt-get dist-upgrade -f

Con el modificador -f (force), la actualización llegó hasta el final aparentemente sin errores.

Como mi distro principal es Debian testing y, por tanto, uso su grub2, me tocó hacer unas ligeras modificaciones allí para usar el nuevo kernel 2.6.38-8-generic (y modificar también el texto identificador para ahora señalar que la distro es la 11.04). Para ello, edité como superusuario la plantilla 30_otheros de Debian testing que se encuentra en /etc/grub.d. Después de grabar las modificaciones, ejecuté update-grub en Debian para que los cambios en su grub2 tuviesen lugar.

Este fue el resultado:

Posiblemente, la clave de este éxito fue seguir personalmente la instalación final en cónsola (que dura unos pocos minutos) para leer los mensajes que arrojaba el gestor en cuanto a la instalación interactiva (“si” a todo lo que implicaba sustitución de los viejos archivos de configuración por los nuevos) y los mensajes de error del sistema. Es posible que los innumerables problemas de actualización que he observado en los foros se deba a que muchos no leen y detectan que el sistema se “rompió”, como fue mi caso (con más de 300 aplicaciones inicialmente con problemas), y reinician. Si uno de los paquetes que tuvo problemas fue el grub2 de Ubuntu (en mi caso no dependo de él), es previsible que el resultado final sea el hecho de que no se podrá acceder ni a Windows.

Esta entrada fue publicada en Linux y etiquetada . Guarda el enlace permanente.

8 respuestas a Actualizar Ubuntu a la versión 11.04 desde la 10.10

  1. Pingback: Impresiones sobre Ubuntu 11.04 |

  2. mcun dijo:

    que buena guía colega… deberías colgarla en la sección documentación de EL asi aparece también en la portada y tiene mas visibilidad… es una solucion a un problema muy recurrente

  3. Pingback: Actualizar Ubuntu a la versión 11.11 desde la 10.11 |

  4. victor manuelle dijo:

    saludos José Guerrero

    mi pregunta es la siguiente, me gustaria saber como haces esta parte en ubuntu con mas detalles, ya que soy nuevo y me gustaria configurar mi ubuntu asi,

    ¨Como mi distro principal es Debian testing y, por tanto, uso su grub2, me tocó hacer unas ligeras modificaciones allí para usar el nuevo kernel 2.6.38-8-generic (y modificar también el texto identificador para ahora señalar que la distro es la 11.04). Para ello, edité como superusuario la plantilla 30_otheros de Debian testing que se encuentra en /etc/grub.d. Después de grabar las modificaciones, ejecuté update-grub en Debian para que los cambios en su grub2 tuviesen lugar.¨

    • Tu quieres instalar Ubuntu. El gestionará todo el proceso de instalación. Yo instalé Ubuntu como segunda distro. La principal era Debian y no quería el grub de Ubuntu. Esto no aplica en tu caso.

  5. victor manuelle dijo:

    saludos nuevamente jose no puedo completar el proceso de instalacion me sale el siguiente error cuando ejecuto el comando
    apt-get dist-upgrade -f

    Extrayendo plantillas para los paquetes: 100%
    Preconfigurando paquetes …
    Configurando python2.7-minimal (2.7.1-5ubuntu2.2) …
    Linking and byte-compiling packages for runtime python2.7…
    E: pycompile:240: Requested versions are not installed
    dpkg: error al procesar python2.7-minimal (–configure):
    el subproceso script post-installation instalado devolvió el código de salida de error 3
    Se encontraron errores al procesar:
    python2.7-minimal
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    si puedes ayudarme gracias.

    • Si eres nuevo en ésto, la actualización por esta vía no es para ti. Haz una “actualización limpia” usando un DVD de instalación de la nueva versión (12.10; aunque pronto estará lista la 13.04). No uses este método porque era para la versión 11.04 desde la 10.10. La equivalente “más reciente” es para la versión 12.10 desde la 12.04. No la ves aquí porque desinstalé Ubuntu definitivamente de mi máquina. No me gusta Gnome 3. Por otra parte, este método es para versiones sucesivas y dará problemas si pretendes pasar, por ejemplo, a la versión 12.10 desde la 10.10.

      Saludos

Responder

Por favor, inicia sesión con uno de estos métodos para publicar tu comentario:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s